Plotting Help.



  • Wondered if anyone here could help me plotting one of my Hard drivers...

    I have been reading up a lot on how to plot, but I keep seeming to run into issues with plotting...

    Am trying to plot a 8TB, (Which says 7.2), not sure if I can format that better?

    Am running Gtx 1070

    0_1487366850135_2017-02-17_21-26.jpg

    This is were I am having trobles, Here is my Devices set up and Makeplotsbat file...

    1_1487366969030_2017-02-17_21-26(3).jpg 0_1487366969029_2017-02-17_21-26(2).jpg

    How I am not sure how to work out the right Nonces for the plot, (would like a goos full 6.8GB plot if poss)

    When I have started the makeplot bat file, it will start off very fast, but then slow down to about 3000 nonces per minute, which is slower then the Cpu plotter on my other Pc.

    0_1487367298951_2017-02-17_21-33.jpg

    I do wonder if i have my setting rights.

    any help would be great.

    Thanks



  • I'm Having the same problem... Hope someone help us solve this problem or figure it out!



  • Don't know about GPU plotting but I can tell you 7.2TB is an 8tB disk.


  • Mod



  • Just my 2cents, but if you have a somewhat decent processor consider using Xplotter to plot with CPU. It is not as fast, but it optimizes the plots and made me feel better about re-doing the tons of GPU plots that were reading slowly without optimization.



  • Thank you very much for your help, Add a few more sticks of ram to the system seems to have helped it running(around 25000/minutes)

    So I am guessing this plot wont be optimizes? And I should use Xplotter to re-plot the drive?



  • I don't get this... If the problem is the drive itself, then why explotter can write more nonces/mimute than the gpu...
    here is my explotter plotting the same drive:
    0_1487462439291_xplotter.png


  • Mod

    @Amoulier you have a good CPU, my 6-core AMD give me max 5200 nonces/min



  • @Blago I got a dual xeon mother board set up... 6 cores each one and 24 threads... kind of overkill workstation to edit videos.



  • Restarted My 8TB with Xplotter....

    Running 2 Pc's to see how we go....

    0_1487525708470_2017-02-19_17-29(2).jpg

    0_1487525716157_2017-02-19_17-29.jpg

    0_1487525727542_2017-02-19_17-30(2).jpg

    0_1487525736125_2017-02-19_17-30.jpg



  • But i'm still have this question unanswered... How is possible that xplotter can write faster than the gpu in the same drive?



  • @Amoulier Your settings for the 1070 are not correct. NVidia is Parallel processing vs AMD Serial. The settings need to be different. I have a post somewhere that we worked out some scenarios. I did it trial and error. Sometimes you will get a CL Error too. But I will be interested in helping you since I want to know what a 1070 can crank out. Let me see if I can find my notes.

    I also noticed you have Buffer Mode on one of the Plotters. If you start in Direct Mode it will be very slow and then ramp up since it is writing Scoops first and then filling the drive with Nonces at the end. It gets very fast towards the end and it really just averages the low out. So Buffer may also be an issue since I just noticed you got to 52K Nonce on that one screenshot.

    So it depends on how you are plotting. XPlotter is Optimizing. Buffered is not.

    Also there is a memory controller that has a specific number that will be the optimal number to use for Plotting on the Nvidia. It matches the Memory vs Group Size for the CL Global variable. I only found this out helping another 970GTX which has a recall due to only 52 not the advertised 64 which makes the memory not allocate properly. I got it tuned and it worked better with that doubled as 104 instead of 52. Not Cuda Cores but some other spec I can't remember right now.

    So where you have 128 the 104 would have gone I believe and then multiples were used as the front number to fill the memory as the size per Nonce would be concerned to scale properly. 256 which is quarter meg etc.



  • @CryptoNick Sorry if i din'd write this earlier but I have a MSI R9 290X:

     PLATFORM-[0] AMD Accelerated Parallel Processing - (OpenCL 2.0 AMD-APP (2264.11))
       *   DEVICE-[0] Hawaii (4GB) - Advanced Micro Devices, Inc. (OpenCL 2.0 AMD-APP (2264.11) | '2264.11')
       *          [0] work group size: '256', computing units: '44', available 'true'
    

    I commented on this thread because the problem is the same.



  • @Amoulier My bad, I responded to you instead of the main topic. So the settings apply to the OP. Not sure why your GPU is slower than the CPU.



  • @Streetlight I used a GTX 1070 myself and had a lot of issues at first. For my devices.txt I use one of these configs based on how much RAM is available:

    0 0 4096 512 128 (uses 1 GB VRAM + 1 GB RAM)
    -OR-
    0 0 8192 512 128 (uses 2 GB VRAM + 2 GB RAM)

    Performance differences are minor between the two configs, so use the lowest config first. I'd recommend writing your plots in direct mode so you don't have to optimize them later.

    gpuPlotGenerator generate direct E://Burst/plots/????????_0_1904640_10240
    gpuPlotGenerator generate direct E://Burst/plots/????????_1904640_1904640_10240
    gpuPlotGenerator generate direct E://Burst/plots/????????_3809280_1904640_10240
    gpuPlotGenerator generate direct E://Burst/plots/????????_5713920_1904640_10240

    And just repeat that pattern, adding 1904640 to the starting nonce each time so you don't overlap. That will make a series of 500GB plot files. If you have more memory, you can bump the stagger size up to 20480 (5GB), but again performance gains are trivial. I decided up front that all my plots would be standardized at 500GB each, so all my math is based on that:

    500 GB Plot Files (NTFS)
    500,050,165,760 bytes (approx.) / 262,144 bytes per nonce = 1,907,540 potential nonces

    2.5 GB RAM
    2,621,440 KB / 256 = 10,240 stagger
    186 * 10,240 = 1,904,640 nonces

    You should get around 13,000 - 15,000 nonces/minute in direct mode and over 20,000 nonces/minute in buffered mode.



  • @sevencardz said in Plotting Help.:

    @Streetlight I used a GTX 1070 myself and had a lot of issues at first. For my devices.txt I use one of these configs based on how much RAM is available:

    0 0 4096 512 128 (uses 1 GB VRAM + 1 GB RAM)
    -OR-
    0 0 8192 512 128 (uses 2 GB VRAM + 2 GB RAM)

    Performance differences are minor between the two configs, so use the lowest config first. I'd recommend writing your plots in direct mode so you don't have to optimize them later.

    gpuPlotGenerator generate direct E://Burst/plots/????????_0_1904640_10240
    gpuPlotGenerator generate direct E://Burst/plots/????????_1904640_1904640_10240
    gpuPlotGenerator generate direct E://Burst/plots/????????_3809280_1904640_10240
    gpuPlotGenerator generate direct E://Burst/plots/????????_5713920_1904640_10240

    And just repeat that pattern, adding 1904640 to the starting nonce each time so you don't overlap. That will make a series of 500GB plot files. If you have more memory, you can bump the stagger size up to 20480 (5GB), but again performance gains are trivial. I decided up front that all my plots would be standardized at 500GB each, so all my math is based on that:

    500 GB Plot Files (NTFS)
    500,050,165,760 bytes (approx.) / 262,144 bytes per nonce = 1,907,540 potential nonces

    2.5 GB RAM
    2,621,440 KB / 256 = 10,240 stagger
    186 * 10,240 = 1,904,640 nonces

    You should get around 13,000 - 15,000 nonces/minute in direct mode and over 20,000 nonces/minute in buffered mode.

    Thank you very much for this. Will give it a go.


Log in to reply
 

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.